ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject Problemes with continuous build
Date Tue, 30 Sep 2008 07:26:44 GMT
Xavier and I set up some build configurations on the CI server TeamCity.
The configurations are listed on http://ant.apache.org/nightlies.html .

But I have problems getting the builds to pass.
All builds are run from the command line with "build.[bat|sh] clean
test".

Subversion revision 700341


These are the machine settings:
- "Windows"
    TeamCity Windows-Agent (WinXP 5.1, JDK 1.5.0_12)
    Overview:
http://teamcity.jetbrains.com/viewType.html?buildTypeId=bt133
    Log:
http://teamcity.jetbrains.com/viewLog.html;jsessionid=BA6A27197A01FE14E6
F4E134379843A0?tab=buildLog&buildTypeId=bt133&buildId=14266&all=true
- "Linux"
    TeamCity Linux-Agent (version 2.6.18-53.1.14.el5, JDK 1.6.0_03)
    Overview: 
    Additional Parameter: -Dantunit.excludes=**/input-test.xml
    -- it seemed that the Linux agent doesnt provide a console
    Log:
http://teamcity.jetbrains.com/viewLog.html;jsessionid=BA6A27197A01FE14E6
F4E134379843A0?tab=buildLog&buildTypeId=bt134&buildId=14267&all=true
- "MyWindows"
    Windows XP on my local notebook (JDK 1.6.0_02)




Testsuite: org.apache.tools.ant.util.VectorSetTest
    WINDOWS  :  Tests run: 20, Failures: 7, Errors: 3, Time elapsed:
0,063 sec
    LINUX    :  Tests run: 20, Failures: 1, Errors: 0, Time elapsed:
0.008 sec
    MYWINDOWS:  Tests run: 20, Failures: 1, Errors: 0, Time elapsed: 0
sec
    
    WINDOWS
        Testcase: testClear --> java.lang.StackOverflowError
        Testcase: testAdd2  --> expected:<1> but was:<0>
            at
org.apache.tools.ant.util.VectorSetTest.testAdd2(VectorSetTest.java:39)
        Testcase: testAddAll2 --> expected:<1> but was:<0>
            at
org.apache.tools.ant.util.VectorSetTest.testAddAll2(VectorSetTest.java:5
5)
        Testcase: testInsertElementAt --> expected:<1> but was:<0>
            at
org.apache.tools.ant.util.VectorSetTest.testInsertElementAt(VectorSetTes
t.java:90)
        Testcase: testRemoveObject --> "null" (no meaningful error
message)
            at
org.apache.tools.ant.util.VectorSetTest.testRemoveObject(VectorSetTest.j
ava:107)
        Testcase: testRemoveAll --> "null"
            at
org.apache.tools.ant.util.VectorSetTest.testRemoveAll(VectorSetTest.java
:114)
        Testcase: testRemoveAllElements --> java.lang.StackOverflowError
        Testcase: testRemoveElement --> "null"
            at
org.apache.tools.ant.util.VectorSetTest.testRemoveElement(VectorSetTest.
java:127)
        Testcase: testRemoveElementAt --> expected:<0> but was:<1>
            at
org.apache.tools.ant.util.VectorSetTest.testRemoveElementAt(VectorSetTes
t.java:135)
        Testcase: testRetainAll --> java.lang.StackOverflowError
    LINUX
        Testcase: testAddAll2 --> expected:<1> but was:<0>
            at
org.apache.tools.ant.util.VectorSetTest.testAddAll2(VectorSetTest.java:5
5)
    MYWINDOWS:
        Testcase: testAddAll2 --> expected:<1> but was:<0>
            at
org.apache.tools.ant.util.VectorSetTest.testAddAll2(VectorSetTest.java:5
5)

        
Testsuite: src\tests\antunit\taskdefs\move-test.xml
    WINDOWS  : Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0,015
sec
    LINUX    : Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.017
sec
    MYWINDOWS: Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0,016
sec

    WINDOWS
        Target: test-move-caseonly --> abc was not renamed aBc
            at line 31, column 80
    MYWINDOWS
        Target: test-move-caseonly --> abc was not renamed aBc
            at line 31, column 80


Testsuite: src\tests\antunit\types\filterset-test.xml
    WINDOWS  : Tests run: 2, Failures: 1, Errors: 0, Time elapsed: 0,063
sec
    LINUX    : Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.029
sec
    MYWINDOWS: Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0,031
sec

    WINDOWS
        Target: testOverlappingMulticharToken --> Expected 'user@host'
but was 'user@@@HOST@@'
            at line 60, column 36


Testsuite: src\tests\antunit\types\firstmatch-test.xml
    WINDOWS  : Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0,015
sec
    LINUX    : Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.013
sec
    MYWINDOWS: Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0,015
sec

    WINDOWS
        Target: testMatch --> copy doesn't support the nested
"firstmatchmapper" element.
            at line 29, column 59



Some ideas?


Jan




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message