ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject AW: Problems with Ant on TeamCity
Date Thu, 25 Sep 2008 13:31:18 GMT
Thanks, I think that was the point.
I added a -Djunit.fork=true without success, so I changed the TC-configuration
to use the command line runner instead of Ant. This results in three configurations
(Windows, Linux, MacOS).

Jan 

>-----Urspr√ľngliche Nachricht-----
>Von: Stefan Bodewig [mailto:bodewig@apache.org] 
>Gesendet: Donnerstag, 25. September 2008 13:39
>An: dev@ant.apache.org
>Betreff: Re: Problems with Ant on TeamCity
>
>On Thu, 25 Sep 2008, Jan Materne <Jan.Materne@rzf.fin-nrw.de> wrote:
>
>> There are problems mit the tests on the CI server
>
>I'd say the problems come from having two versions of Ant on the
>classpath.  CI probably uses one itself.
>
>For example 
>
>,----
>| StringUtilsTest.testRemovePrefix  (org.apache.tools.ant.util)
>|     java.lang.NoSuchMethodError: 
>org.apache.tools.ant.util.StringUtils.removePrefix(Ljava/lang/S
>tring;Ljava/lang/String;)Ljava/lang/String;
>`----
>
>really looks suspicious.
>
>Forking the tests may help.
>
>Stefan
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
>For additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message