ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scheper, Erik-Berndt" <erik-berndt.sche...@sogeti.nl>
Subject RE: [ivy] ivy:install failure for Axis2 1.4 and derivatives from repo1.maven.org
Date Mon, 09 Jun 2008 12:29:11 GMT
XmlSchema-1.4.2 that is. 

________________________________

Van: Scheper, Erik-Berndt [mailto:erik-berndt.scheper@sogeti.nl]
Verzonden: ma 9-6-2008 14:15
Aan: Ant Developers List
Onderwerp: RE: [ivy] ivy:install failure for Axis2 1.4 and derivatives from repo1.maven.org



Great!

Please note that this does not only concern Axiom, but org.apache.neethi.neethi-2.0.4 and
org.apache.commons.ws.schema.XmlSchema-2.0.4 as well.

Did you contact them too?

Many thanks, Erik-Berndt

________________________________

Van: Gilles Scokart [mailto:gscokart@gmail.com]
Verzonden: ma 9-6-2008 13:40
Aan: Ant Developers List
Onderwerp: Re: [ivy] ivy:install failure for Axis2 1.4 and derivatives from repo1.maven.org



The problem comes from the repository, not from ivy.  I have alreay
tried to contact the axiom people but didn't get any response yet.  I
will try to relaunch them.



2008/6/9 Scheper, Erik-Berndt <erik-berndt.scheper@sogeti.nl>:
> Hi,
>
> I am trying to copy the Axis2 1.4 libraries and their derivatives from repo1.maven.org.
> However, this fails due to an MD5 difference.
>
> [ivy:install] CLIENT ERROR: Not Found url=http://repo1.maven.org/maven2/org/apache/ws/commons/axiom/axiom-api/1.2.7/axiom-api-1.2.7.pom.sha1
> [ivy:install]  repo1.maven.org: downloading http://repo1.maven.org/maven2/org/apache/ws/commons/axiom/axiom-api/1.2.7/axiom-api-1.2.7.pom.md5
> [ivy:install]  [FAILED     ] org.apache.ws.commons.axiom#axiom-api;1.2.7!axiom-api.pom(pom.original):
invalid md5: expected=\d679962e170ce87fc7e9e13d338c82bf computed=d679962e170ce87fc7e9e13d338c82bf
(1328ms)
> [ivy:install] WARN: problem while downloading module descriptor: http://repo1.maven.org/maven2/org/apache/ws/commons/axiom/axiom-api/1.2.7/axiom-api-1.2.7.pom:
invalid md5: expected=\d679962e170ce87fc7e9e13d338c82bf computed=d679962e170ce87fc7e9e13d338c82bf
(1328ms)
>
>
> The problem is that the MD5 hashes in the maven repository contain a preceding \ character.
> Are the MD5 hashes invalid, or is this a bug in the Ivy install task?
>
>
> Regards,
>
> Erik-Berndt
>
>
>
>
>
>
> Disclaimer:
> This message contains information that may be privileged or confidential and is the property
of Sogeti Nederland B.V. or its Group members. It is intended only for the person to whom
it is addressed. If you are not the intended recipient, you are not authorized to read, print,
retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive
this message in error, please notify the sender immediately and delete all copies of this
message.
>



--
Gilles Scokart

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org




Disclaimer:

This message contains information that may be privileged or confidential and is the property
of Sogeti Nederland B.V. or its Group members. It is intended only for the person to whom
it is addressed. If you are not the intended recipient, you are not authorized to read, print,
retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive
this message in error, please notify the sender immediately and delete all copies of this
message.




Disclaimer:
This message contains information that may be privileged or confidential and is the property
of Sogeti Nederland B.V. or its Group members. It is intended only for the person to whom
it is addressed. If you are not the intended recipient, you are not authorized to read, print,
retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive
this message in error, please notify the sender immediately and delete all copies of this
message.


Mime
View raw message