ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: Fixing some naming inconsistencies in Ivy
Date Thu, 03 Apr 2008 11:37:21 GMT
I've fixed IVY-297 with the changes suggested for allownomd and
skipbuildwithoutivy. I've also opened IVY-789 to support descriptor as a
more generic name for module descriptor patterns in resolvers configuration.

Xavier

On Mon, Mar 31, 2008 at 1:43 PM, Maarten Coene <maarten_coene@yahoo.com>
wrote:

> I like the enumeration syntax, like descriptor="required | otpional", it's
> much more readable and it will probably allow us to have less attributes on
> some of the tasks.
>
> Maarten
>
> ----- Original Message ----
> From: Xavier Hanin <xavier.hanin@gmail.com>
> To: Ant Developers List <dev@ant.apache.org>
> Sent: Saturday, March 29, 2008 10:09:23 AM
> Subject: Re: Fixing some naming inconsistencies in Ivy
>
> Just pinging about this e-mail, I've had no answer so far, I think I can't
> make the choice alone, and we need to deal with that question before
> 2.0final to close IVY-297. So, anyone has an opinion about this:
>
> On Fri, Feb 29, 2008 at 12:31 PM, Xavier Hanin <xavier.hanin@gmail.com>
> wrote:
>
> > Hi,
> >
> > As reported by IVY-297, Ivy suffers from some name inconsistencies and
> > strange attribute names. Ivy 2.0 is a good opportunity to fix some of
> > them, since I think we can afford some more deprecation warnings.
> >
> > So I'd like to fix IVY-297 by marking allownomd as deprecated, and
> > providing a descriptor="required | optional" attribute.
> >
> > To go further, we could rename the attribute skipbuildwithoutivy in
> > buildlist in skipbuildwithoutdescriptor, or even better change it to
> > buildwithoutdescriptor="skip | fail | warn | tail | head", which wold
> make
> > it both more readable and more powerful.
> >
> > Another area where the name 'ivy' is used to talk about module
> descriptors
> > in general is patterns. This lead to some strange settings, where you
> give
> > an 'ivy' pattern to tell where the poms are. In this case I think we
> could
> > support both 'ivy' and 'descriptor' (for resolver patterns for
> instance),
> > since the use case for ivy files is still predominant, so I don't think
> > deprecating the old name would really be better.
> >
> > So, what do you think about these changes?
> >
> > Xavier
> >
> >
> --
> Xavier Hanin - Independent Java Consultant
> http://xhab.blogspot.com/
> http://ant.apache.org/ivy/
> http://www.xoocode.org/
>
>
>
>
>
>
>  ____________________________________________________________________________________
> Looking for last minute shopping deals?
> Find them fast with Yahoo! Search.
> http://tools.search.yahoo.com/newsearch/category.php?category=shopping
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>


-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message