ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@anyware-tech.com>
Subject Upgrading the version of IvyDE
Date Wed, 16 Apr 2008 12:59:16 GMT
Hi,

I would like to upgrade the version of IvyDE to 2.0. The trunk version is 
currently tagged to be an 1.3. I would like to make this upgrade for sevral 
reasons:
- the trunk version of IvyDE is relying on Ivy 2 whereas the last released 
version of IvyDE (1.2.1) is using Ivy 1.4.1. From a user point of view this 
will be easier to understand which version of IvyDE match which version of 
Ivy.
- the plugin ID of IvyDE changed. For the 1.2.1 it was 
org.jayasoft.ivyde.eclipse and now it is org.apache.ivyde.eclipse. So users 
won't be able to update their plugins. Actually they will appear as two 
different plugins.
- recently, due to a major bug fix (IVYDE-70), the preference are not managed 
the same way, the way to configure IvyDE changed. Having a version upgrade 
will make user aware of big changes.

I also think that some other refactoring may appear (IVYDE-32), so I think 
that IvyDE require a new version number regarding these big changes.

WDYT ?

Nicolas

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message