ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Sandor" <adi...@gmail.com>
Subject Re: Possible Ivy resolver bug
Date Sat, 09 Feb 2008 12:00:51 GMT
On Feb 9, 2008 5:49 PM, Xavier Hanin wrote:

> > I see that now, but everything I tried with the ant build script ended
> up
> > with this:
> > /mnt/tc/workspace/ivy-trunk/build.xml:50: ivy:settings doesn't support
> the
> > "override" attribute
>
> Check the list archive or JIRA, others have already complained about that
> very recently, the problem is most probably due to another version of Ivy
> in
> your ant lib.
>

Google didn't find anything, hope it will index these messages from one of
the archives.
I found IVY-718 in JIRA, and indeed I had a similar problem (Ivy 2.0.0 beta1
added to the ant home entries in eclipse).
After removing that, deleting the lib folder and the Ivy cache, I was able
to build the jar, and I get no more errors in eclipse.
I think it would help to have more instructions in the README or somewhere,
explaining the ant targets and perhaps warning against using other Ivy
versions with ant. Or at least a reference to dev.html.

Thanks
Adrian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message