ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: [DISCUSS] release Ivy 2.0.0-beta2?
Date Mon, 11 Feb 2008 08:20:05 GMT
On Feb 11, 2008 7:18 AM, Adrian Sandor <aditsu@gmail.com> wrote:

> On Feb 11, 2008 4:24 AM, Xavier Hanin wrote:
>
> > > - 3 tags for cache configuration: settings, caches and cache
> >
> > The settings on the settings tag are mainly due to legacy. We could
> indeed
> > deprecate them to move all cache settings to the caches element. cache
> > element should now only the defition of one cache, so I don't see how we
> > could avoid that.
>
>
> I also said "cache" tags could be ok as they are now. Two tags (caches and
> cache) are acceptable.
>
>
> > > - inconsistent/confusing attributes on the settings tag: defaultCache
> > and
> > > resolutionCacheDir - different naming styles although they're both
> > > directories; and both of them specify the resolution cache but
> > > defaultCache
> > > also specifies the repository cache?
> >
> > Yes, this is a legacy problem, but I agree it's confusing. Maybe we can
> > rename it to defaultCacheDir, and deprecate defaultCache.
>
>
> So, if I understand correctly, right now settings/defaultCache is the
> default for both resolution and repository cache;
> settings/resolutionCacheDir overrides it for resolution, caches/basedir
> overrides it for repository, and cache/basedir overrides caches/basedir
> (for
> repository).

Exactly, and I agree this is confusing :-)

>
> Perhaps we can move settings/resolutionCacheDir to
> caches/resolutionCacheDir, rename caches/basedir to
> caches/repositoryCacheDir, and either remove settings/defaultCache or move
> it to caches/defaultCacheDir.

It makes sense. For defaultCache, I think we need to keep and rename it, for
Ivy 1.x users who where used to it (and it eases the way to define where all
Ivy cache data goes, which is the most common use case.

Do anybody else see any problem with these changes?


>
> > > - some confusion between "defaultCache" on settings, "default" on
> > caches,
> > > and "default-cache"
> >
> > Again, if we rename defaultCache in defaultCacheDir, I think this would
> be
> > less confusing. Would this be enough in your opinion?
>
>
> It would definitely help. Probably good enough, if the docs are clear.
>
>
> > > - ivy and artifact patterns everywhere
> >
> > What's the problem with that? Could you elaborate?
>
>
> settings/cacheIvyPattern and settings/cacheArtifactPattern vs
> caches/ivyPattern and caches/artifactPattern, they're redundant.

Indeed, and I've actually deprecated settings/cache*, except that I forgot
to update the doc.

>
>
> Also these have changed since beta 1 (cache/repositoryIvyPattern and
> cache/repositoryArtifactPattern), and so did the resolution/repository dir
> attributes. Change itself is not bad, we should just make sure the new way
> is really better.

You're right, but with eyeballs of a new user who is not corrupted by
several years of Ivy experience I'm pretty sure we'll find a good way to
make this clear enough!

Thanks again for your feedback.

Xavier

>
>
> Adrian
>



-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message