ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: [DISCUSS] release Ivy 2.0.0-beta2?
Date Sun, 10 Feb 2008 20:24:12 GMT
On Feb 10, 2008 8:18 PM, Adrian Sandor <aditsu@gmail.com> wrote:

> On Feb 10, 2008 4:52 PM, Xavier Hanin wrote:
>
> > We have made good progress on Ivy trunk, and I think it's close to be a
> > good
> > time to release 2.0.0 beta 2. So, do you see anything blocking before
> > cutting this release? Anything you would like to see in? Any pending
> > change
> > that would deserve to wait?
>
>
> Well, nothing critical, but I've been quite shocked by the changes in the
> cache management:
> - 3 tags for cache configuration: settings, caches and cache

The settings on the settings tag are mainly due to legacy. We could indeed
deprecate them to move all cache settings to the caches element. cache
element should now only the defition of one cache, so I don't see how we
could avoid that. Unless we don't allow changing defaults for all caches at
once, and make per cache settings mandatory.

>
> - inconsistent/confusing attributes on the settings tag: defaultCache and
> resolutionCacheDir - different naming styles although they're both
> directories; and both of them specify the resolution cache but
> defaultCache
> also specifies the repository cache?

Yes, this is a legacy problem, but I agree it's confusing. Maybe we can
rename it to defaultCacheDir, and deprecate defaultCache.

>
> - some confusion between "defaultCache" on settings, "default" on caches,
> and "default-cache"

Again, if we rename defaultCache in defaultCacheDir, I think this would be
less confusing. Would this be enough in your opinion?

>
> - ivy and artifact patterns everywhere

What's the problem with that? Could you elaborate?

Thanks for your feedback,

Xavier

>
>
> I managed to work it out (using only one cache, thank you very much!), but
> I
> really think this stuff can be greatly improved, at least by
> moving/merging
> all the cache-related attributes from "settings" to "caches" and giving
> them
> better names. "cache" tags could be ok as they are now.
> If there are legacy compatibility requirements, the old-style attributes
> can
> still be supported but deprecated.
>
> Regards,
> Adrian
>



-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message