ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin" <xavier.ha...@gmail.com>
Subject Re: Possible Ivy resolver bug
Date Sun, 10 Feb 2008 08:23:59 GMT
On Feb 9, 2008 1:00 PM, Adrian Sandor <aditsu@gmail.com> wrote:

> On Feb 9, 2008 5:49 PM, Xavier Hanin wrote:
>
> > > I see that now, but everything I tried with the ant build script ended
> > up
> > > with this:
> > > /mnt/tc/workspace/ivy-trunk/build.xml:50: ivy:settings doesn't support
> > the
> > > "override" attribute
> >
> > Check the list archive or JIRA, others have already complained about
> that
> > very recently, the problem is most probably due to another version of
> Ivy
> > in
> > your ant lib.
> >
>
> Google didn't find anything, hope it will index these messages from one of
> the archives.
> I found IVY-718 in JIRA, and indeed I had a similar problem (Ivy 2.0.0beta1
> added to the ant home entries in eclipse).
> After removing that, deleting the lib folder and the Ivy cache, I was able
> to build the jar, and I get no more errors in eclipse.
> I think it would help to have more instructions in the README or
> somewhere,
> explaining the ant targets and perhaps warning against using other Ivy
> versions with ant. Or at least a reference to dev.html.

Agreed. We'd need to check in our build if another version of Ivy is loaded
from ant lib, and output a warning in this case. We'd also need to add maybe
a help target pointing to dev.html, and explain also in dev.html that you
need to make sure you don't have an ivy.jar in your ant lib.

Could you open a JIRA issue about that?

Xavier

>
>
> Thanks
> Adrian
>



-- 
Xavier Hanin - Independent Java Consultant
http://xhab.blogspot.com/
http://ant.apache.org/ivy/
http://www.xoocode.org/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message