ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Sandor <adi...@yahoo.com>
Subject Re: Possible Ivy resolver bug
Date Sat, 09 Feb 2008 09:27:17 GMT
> Not 
sure 
what 
you 
mean 
by 
complete 
binary.

I mean a jar ready to use, just like the ivy-2.0.0-beta1.jar included in the binary download.

> Calling 
"ant 
jar" 
creates ivy.jar in 
build/artifacts/jars/ 
and 
copy 
it 
with 
an 
eclipse 
bundle name 
in
> build/artifacts/. 
That's 
all 
you 
should 
need, 
and 
this 
is 
documented 
on 
the
> download 
page, 
in 
the 
build 
from 
source 
section.

I see that now, but everything I tried with the ant build script ended up with this:
/mnt/tc/workspace/ivy-trunk/build.xml:50: ivy:settings doesn't support the "override" attribute

> Is 
there 
something 
missing? 
Any 
detail 
on 
why 
you 
fumbled 
to 
build 
the 
jar?

Well, there was no .classpath, no jars (dependencies), and no instructions  included. Even
after I downloaded the jars with IvyDE, I got hundreds of errors in the unit tests, such as:
Implicit super constructor TestCase() is not visible for default constructor. Must define
an explicit constructor
Probably a bad junit version?


Anyway, even now, I'm still unable to build a jar. I just ran org.apache.ivy.Main from eclipse.

Adrian




      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message