ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <foamd...@gmail.com>
Subject Re: AW: ant java versions
Date Wed, 16 Jan 2008 02:17:20 GMT
Hi all,

> To me, the super-compelling reason is that if we claim to support Java
> 1.3, then we have to make sure to test against it on all supported
> platforms. This is a lot of extra work (on top of the testing for 1.4,
> 1.5, and 1.6), particularly if none of us has Java 1.3 installed. This
> has bitten us in the past, where JDK 1.2 support in Ant broke without
> anybody realizing it. Since Java 1.3 is at end of life, what is the
> benefit to keeping it?

I agree with this - I've tried to build our current 1.7.1 branch on
1.3 and it simply won't build right now (I can't remember the exact
error I think it was XML api related).  Sun don't support java 1.3
(indeed 1.4 will soon be end of life).

Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message