ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Atherton <br...@callenish.com>
Subject Re: AW: ant java versions
Date Tue, 15 Jan 2008 18:05:19 GMT
To me, the super-compelling reason is that if we claim to support Java 
1.3, then we have to make sure to test against it on all supported 
platforms. This is a lot of extra work (on top of the testing for 1.4, 
1.5, and 1.6), particularly if none of us has Java 1.3 installed. This 
has bitten us in the past, where JDK 1.2 support in Ant broke without 
anybody realizing it. Since Java 1.3 is at end of life, what is the 
benefit to keeping it?

It is true that we will see the real benefit in the codebase once we can 
support only 1.5 and higher, but deprecating support for Java 1.3 is a 
step to getting us there. Ant 1.8 can target Java 1.4, and then Ant 1.9 
(2.0?) can target 1.5. That way the Java versions we support are 
deprecated gradually.

Peter Reilly wrote:
>
>
> I do not think we should do this.
> As far as I know, there is no super compelling reason to make ant only
> work on java 1.4 +,
>
> java5, on the other hand....
>
> Peter
>
>   
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message