ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <nicolas.lale...@anyware-tech.com>
Subject Re: Ivy Repository
Date Sun, 30 Dec 2007 11:59:23 GMT

Le 30 déc. 07 à 11:37, Markus M. May a écrit :

> Hello,
>
> I got IVYDE from the repository and tried to build it. It tries to  
> find IVY in the repository http://repo1.maven.org/maven2/apache  
> which is non-existant.
> I think as one of the primary projects using the reposoitory, we  
> should definitly put IVY in the repository, right?
>
> Anyway, I will now change the dependency, so that IVYDE uses the  
> newest version of IVY on my local machine.

The dependencies of IvyDE have recently changed. Ivy is now an eclipse  
bundle, and so IvyDE depends on Ivy via the "Plug-in Dependencies". So  
as soon as you mount ivy and ivyde in Eclipse, the dependencies should  
be resolved automagically by Eclipse itself. You don't need anymore  
doing a "ant resolve".

Note also that IvyDE does not compile as there were some API change in  
Ivy. While providing a patch in IVYDE-68 I have fixed those.

cheers,
Nicolas


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message