ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43554] New: - ANTLR task is incompatible with recent ANTLR 3.x
Date Thu, 04 Oct 2007 19:05:59 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43554>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43554

           Summary: ANTLR task is incompatible with recent ANTLR 3.x
           Product: Ant
           Version: 1.7.0
          Platform: All
               URL: http://www.antlr.org/wiki/display/ANTLR3/Migrating+from+
                    ANTLR+2+to+ANTLR+3
        OS/Version: All
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: jorge.martins@ieee.org


When invoking the ANTLR ant task, it fails with:
    [antlr] java.lang.NoClassDefFoundError: antlr/Tool
    [antlr] Exception in thread "main"

this happens everytime with ANTLR 3. The reason is explained in their migration
notes (link on URL field): there was a package change and the "Tool" class that
is invoked by the antlr task now belongs to "org.antlr" package instead of
"antlr" as in previous versions.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message