ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <foamd...@gmail.com>
Subject Bugs in release branch
Date Sat, 27 Oct 2007 08:39:19 GMT
Hi,

On Windows with JDK6, the following tests fail:

FileUtilsTest.testHasErrorInCase()

RmicAdvancedTest.testXnew

RmicAdvancedTest.testXnewForked	
Error	org.apache.xerces.parsers.XIncludeAwareParserConfiguration
cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration

RmicAdvancedTest.testXnewCompiler
Error	org.apache.xerces.parsers.XIncludeAwareParserConfiguration
cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration

RmicAdvancedTest.testIDL
Error	org.apache.xerces.parsers.XIncludeAwareParserConfiguration
cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration

RmicAdvancedTest.testIIOP
Error	org.apache.xerces.parsers.XIncludeAwareParserConfiguration
cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration

LocatorTest.testNetworkURI	
Failure	Expected file:\\PC03\jclasses\lib\ant-1.7.0.jar to resolve to
\\PC03\jclasses\lib\ant-1.7.0.jar but got
D:\\PC03\jclasses\lib\ant-1.7.0.jar
expected:<[]\\PC03\jclasses\lib\...> but
was:<[D:]\\PC03\jclasses\lib\...>

LocatorTest.testUnixNetworkPath	
Failure	Expected file://cluster/home/ant/lib to resolve to
//cluster/home/ant/lib but got D:\\cluster\home\ant\lib
expected:<[//cluster/home/ant/]lib> but
was:<[D:\\cluster\home\ant\]lib>

LocatorTest.testUnixNetworkPath13
Failure	Expected file://cluster/home/ant/lib to resolve to
//cluster/home/ant/lib but got D:\\cluster\home\ant\lib
expected:<[//cluster/home/ant/]lib> but
was:<[D:\\cluster\home\ant\]lib>

LocatorTest.testUnixPath
Failure	Expected file:/home/ant/lib to resolve to /home/ant/lib but
got D:\home\ant\lib expected:<[/home/ant/]lib> but
was:<[D:\home\ant\]lib>

LocatorTest.testInternationalURI
Failure	Expected file:/D:/L/u00f6wenbrau/aus/M/u00fcnchen to resolve
to /L\u00f6wenbrau/aus/M\u00fcnchen but got
D:\L\u00f6wenbrau\aus\M\u00fcnchen
expected:<[/L\u00f6wenbrau/aus/]M\u00fcnchen> but
was:<[D:\L\u00f6wenbrau\aus\]M\u00fcnchen>

LocatorTest.testOddLowAsciiURI
Failure	Expected file:/D:/hash%23/%20and%20/percent%25 to resolve to
/hash#/ and /percent% but got D:\hash#\ and \percent%
expected:<[/hash#/ and /]percent%> but was:<[D:\hash#\ and \]percent%>


Does anyone else have these errors from the current 1.7.1 branch?

Thanks,
Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message