ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 25734] - XmlLogger doesn't log when parallel is used.
Date Fri, 12 Oct 2007 21:30:05 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=25734>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=25734





------- Additional Comments From Craig.Sandvik@sybase.com  2007-10-12 14:30 -------
We are hitting a similar issue in our nightly build, running Ant 1.6.5 on 
Linux. This build runs a lot of parallel tasks, and occasionally the XML log 
loses task and target elements that should appear as children of the main build 
element. The XML log is well formed, but incomplete -- there are targets that 
complete with no corresponding log output. The build itself finishes 
successfully, and the unlogged targets appear to run successfully (expected 
build products are created and separate logs from forked parallel builds are 
complete). We aren't able to reproduce this reliably in testing on the same 
input that failed the night before, and it does not happen every run of the 
nightly build. It may be related to timing issues with clearcase server access, 
copying across network file systems, etc.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message