ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Reilly" <peter.kitt.rei...@gmail.com>
Subject Re: ant really slow, 100% CPU?
Date Wed, 19 Sep 2007 13:27:23 GMT
It is with tests or without?

ie. ./build.sh, or ./build.sh test

Peter

On 9/19/07, Peter Reilly <peter.kitt.reilly@gmail.com> wrote:
> I have not noticed any slowdown.
> ./build.sh on a clean system report 18 seconds to compile
> everything (excluding the optional regexp, oro and netrexx jars)
>
> Peter
> ...
> test-jar:
>
> dist-lite:
>      [copy] Copying 20 files to /work/reilly/svn/ant/trunk/dist/lib
>
> main:
>
> BUILD SUCCESSFUL
> Total time: 18 seconds
>
>
>
> On 9/19/07, Steve Loughran <stevel@apache.org> wrote:
> >
> >
> > I've just rebuilt ant and now its really, really slow to build. I've
> > just rolled back those extra synchronized bits I'd added, and that
> > doesnt seem to be it.
> >
> > -its spinning at 100%, and its memory footprint is high, even given that
> > this is a 64-bit JVM:
> >
> >
> >    PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
> >
> > 24273 slo       17   0 1402m 326m 9512 S  100  5.5   2:18.35 java
> >
> > it could be swapping, but heap useage is actually pretty slow (currently
> > about 50MB, according to jconsole).
> >
> > -can anyone think of an obvious change in the last couple of months that
> > would slow things down?
> > -has anyone else noticed a change in performance?
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> > For additional commands, e-mail: dev-help@ant.apache.org
> >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message