ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 42838] - Support for JSR 199: Java Compiler API
Date Tue, 10 Jul 2007 01:42:35 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=42838>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=42838





------- Additional Comments From carej@us.ibm.com  2007-07-09 18:42 -------
(In reply to comment #5)

> So if the current JVM is __Java 6__, then using new API would be a right thing
> to do.

I suppose that depends on your definition of "current". Unless I missed
something, Ant is still supporting previous JVMs, so that means whomever
implements support for this JSR is going to have to pull out the usual bag of
tricks to check for JDK versions, etc.

I'm not suggesting that it's not worthwhile or that Ant shouldn't adopt this;
I'm just trying to temper the rampant enthusiasm by pointing out that this JSR
is just a __little__ bit late in coming...


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message