ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: Trunk not buildable on Java 1.3
Date Mon, 21 May 2007 09:41:40 GMT
Jan.Materne@rzf.fin-nrw.de wrote:
> build.bat build
> 
> src\tests\junit\org\apache\tools\ant\launch\LocatorTest.java:23: cannot
> resolve symbol
> location: package net
> import java.net.URISyntaxException;
>                 ^
> 
> 
> 
> C:\ant\svn-repository\ant\core\src\tests\junit\org\apache\tools\ant\laun
> ch\LocatorTest.java:66: cannot resolve symbol
> 
> symbol  : method toURI  ()
> 
> location: class java.io.File
>         String asuri = new File(path).toURI().toASCIIString();
>                        ^
> 
> 
> 
> URI was introduced in 1.4 and I think URISyntaxException, too  (no
> @since in my JDK javadoc ;)
> But we want to be buildable on JDK 1.3.
> a) make LocatorTest 1.3-compliant
> b) make LocatorTest optional (--> build.xml)

To test this we need to compare 1.4 and 1.3 semantics, so it needs to be 
1.4+ only.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message