ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Kruithof <...@apache.org>
Subject Re: Probable bug found: scp task does not handle correctly directories containing subdirectories
Date Tue, 01 May 2007 16:02:30 GMT
Please verify this with an older (0.1.29) version of jsch or with the 
latest Ant (nightly build) before submitting a bugreport.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41090

br Martijn

Jean-Noël Rivasseau schreef:
> Hi, I posted this on the user list but noone answered, I have better luck
> here.
>
> I am using Ant 1.6.5 and Ant 1.7 on Gentoo Linux amd64, and the same
> behavior appears.
>
> When using the scp task, I cannot copy a directory that contains
> subdirectories. When copying a directory that has no subdirectories, 
> things
> work fine, but any directory with subdirs in it will cause the scp 
> task to
> hang.
>
> By hang, I mean that the scp task when Ant is loaded from the command 
> line
> never finishes.
>
> Should a bug report be filed? Is this normal behavior?
>
> My code:
>
>    <scp todir="elvanor@elvanor.net :/home/elvanor/test/" port="23"
> keyfile="${user.home}/.ssh/id_rsa" passphrase="" verbose="true">
>        <fileset dir="build/WEB-INF/classes" includes="**/*" />
>    </scp>
>
> Note that there are no errors related to authentication or whatever. Just
> changing the fileset dir attribute to some directory that has no
> subdirectories makes the whoile thing work perfectly.
>
> Jean-Noël


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message