ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Kruithof <...@apache.org>
Subject Re: minimum supported Java version
Date Mon, 23 Apr 2007 13:42:30 GMT

I believe it still is Java 1.2.

I cannot test the standard builds on it anymore and for my linux 
environment i cannot build and test it anymore.

I remember some discussion from 2 years ago vaguely but can't remember if 
it came to a vote.

I'd vote in favour of dropping support for both 1.2 and 1.3 if a vote was 
called. (both 1.2 and 1.3 have completed the SUN EOL process)
(1.3 on solaris 8 is still in the EOL process as per customer support 
agreement)

I could see this as a general mechanism, we do not support jdks in 
new releases anymore that have completed the end of life process.

Martijn

On Mon, 23 Apr 2007, Steve Loughran wrote:

>
>
> What is our minium Java version these days? Java 1.3?
>
> IntrospectionHelper has some stuff (EMPTY_MAP) that is only needed for 1.2 
> support, so if we are on java1.3+, I could strip it
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> For additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message