ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: minimum supported Java version
Date Mon, 23 Apr 2007 15:49:54 GMT
Peter Reilly wrote:
> On 4/23/07, Jan.Materne@rzf.fin-nrw.de <Jan.Materne@rzf.fin-nrw.de> wrote:
>> AFAIK it's 1.2.
>>
>> Manual "System Requirements"
>> For the current version of Ant, you will also need a JDK installed on 
>> your system, version 1.2 or later required, 1.5 or later strongly 
>> recommended. The later the version of Java , the more Ant tasks you get.
> 
>>
>>
>> If i remember right we said
>> - build on 1.3
>> - run on 1.2
> 
> We need to build the released version of ant on 1.5.
> javac 1.5 (sun's version) does not create a class files
> that are complety compatible on java 1.2 run time
> - see manual/platform.html.
> 
> Peter

OK, so we are java1.3+ now. Excellent.

I have a hard time remembering what is in old versions past java1.4/I 
have the 1.4/1.5 split as I still have to target both, and use java 1.6 
most places (today I'm getting ant to pass its tests on it)

-steve

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message