ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <foamd...@gmail.com>
Subject Ant 1.7.0 Maven2 repo version has problem
Date Tue, 13 Feb 2007 04:37:25 GMT
Hi,

The version of 1.7.0 at the maven2 repo seems to have a problem.

my pom :

<dependency>
  <groupId>org.apache.ant</groupId>
  <artifactId>ant</artifactId>
  <version>[1.7.0,)</version>
</dependency>
		
<dependency>
  <groupId>org.apache.ant</groupId>
  <artifactId>ant-jsch</artifactId>
  <version>[1.7.0,)</version>
</dependency>

When I use my maven plugin (which relies on these dependencies) I get
a URL error in ${user.home}/.m2/repository/org/apache/ant/ant/1.7.0/ant-1.7.0.jar

When I change the dependencies to version 1.6.5 (and the groupId to
ant mvn1 style), my plugin works fine.

I'm wondering if the 1.7.0 jar at the mvn2 repo is corrupted in some
way?  Opening it and looking at the classes it seems fine.

Any ideas?
Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message