ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41413] New: - ant copy to wrong directory
Date Fri, 19 Jan 2007 16:11:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41413>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41413

           Summary: ant copy to wrong directory
           Product: Ant
           Version: 1.7.0
          Platform: Other
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: mlwl@gft.com


For some directories ant copies files into the wrong directory. The example show
s that Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html is copied into
BankCodeSearch.wo/BankCodeSearch.html and hence overwrites the different files
in BankCodeSearch.wo/BankCodeSearch.html

This happens not in ant version 1.6.1.

example:
wrong in 1.7.0:
[woapplication] Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html added as
Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication] Banking.subproj/BankCodeSearch.wo/BankCodeSearch.html added as
BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication]
Banking.subproj/Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html added as
BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication] Copying
/home/iceadm/src/apps/Viper/Banking.subproj/Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html
to
/home/iceadm/src/apps/Viper/dist/dbpbc.woa/Contents/Resources/BankCodeSearch.wo/BankCodeSearch.html
[woapplication] Copying
/home/iceadm/src/apps/Viper/Banking.subproj/BankCodeSearch.wo/BankCodeSearch.html
to
/home/iceadm/src/apps/Viper/dist/dbpbc.woa/Contents/Resources/BankCodeSearch.wo/BankCodeSearch.html


ok in 1.6.1:
[woapplication] Banking.subproj/BankCodeSearch.wo/BankCodeSearch.html added as
BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication]
Banking.subproj/Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html added as
BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication] Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html added as
Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html doesn't exist.
[woapplication] Copying
/Users/iceadm/work/src/apps/Viper/Banking.subproj/BankCodeSearch.wo/BankCodeSearch.html
to
/Users/iceadm/work/src/apps/Viper/dist/dbpbc.woa/Contents/Resources/BankCodeSearch.wo/BankCodeSearch.html
[woapplication] Copying
/Users/iceadm/work/src/apps/Viper/Banking.subproj/Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html
to
/Users/iceadm/work/src/apps/Viper/dist/dbpbc.woa/Contents/Resources/Mobile.lproj/BankCodeSearch.wo/BankCodeSearch.html

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message