ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41392] - TimingLogger
Date Wed, 17 Jan 2007 16:24:05 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41392>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41392





------- Additional Comments From jain@gmx.net  2007-01-17 08:24 -------
I've tried to subclass DefaultLogger, but ran into this problem:

Unless I call setOutputPrintStream(System.out) in the constructor of the
otherwise still empty subclass, I get this:

Buildfile: build.xml

...

BUILD SUCCESSFUL
Total time: 1 second
java.lang.NullPointerException: 
        at org.apache.tools.ant.DefaultLogger.printMessage(DefaultLogger.java:321)
        at org.apache.tools.ant.DefaultLogger.buildFinished(DefaultLogger.java:162)
        at org.apache.tools.ant.Project.fireBuildFinished(Project.java:2008)
        at org.apache.tools.ant.Main.runBuild(Main.java:718)
        at org.apache.tools.ant.Main.startAnt(Main.java:199)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

If I do set "out", I get a duplicate "BUILD SUCCESSFUL" message:

BUILD SUCCESSFUL
Total time: 1 second

BUILD SUCCESSFUL
Total time: 1 second

Should I open a separate issue for this, or is this behavior intended?


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message