ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Jackson" <>
Subject Re: [VOTE] Release of Apache Ant 1.7.0
Date Wed, 13 Dec 2006 10:05:13 GMT
> The code uses reflection so it should compile on jdk 1.5 and
> work on jdk 1.6.

I put a conditional compile in the build.xml file so that the
hasfreespace code isn't even compiled on pre 1.6 jdks :

<selector id="needs.jdk1.6+">
      <filename name="${condition.package}/HasFreeSpace*"/>
  	  <filename name="${util.package}/java16/*"/>

In reality, HasFreeSpace can be compiled on java5 (and lower), I put
this into the build previously and didn't take it out - that would
prevent the build from compiling the new code for this release (as
there are no docs either, I initially thought it would be better to
not ship the actual compiled version for 1.7.0 and put this in to
prevent that from happening)

> The unittests should check for jdk 1.6 and ignore the test
> if run on a jdk less that 1.6.

I've just committed your recommended change to use <available> to skip
the test on java5 and lower


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message