ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: [VOTE] Release of Apache Ant 1.7.0
Date Wed, 13 Dec 2006 09:45:56 GMT
On Dec 13, 2006, at 4:26 AM, Peter Reilly wrote:

> On 12/13/06, Jan.Materne@rzf.fin-nrw.de <Jan.Materne@rzf.fin- 
> nrw.de> wrote:
>> -1: doesnt compile on JDK-1.2.1_004:
>
> or jdk 1.3.
>
>>
>> src\main\org\apache\tools\ant\util\StringUtils.java:205: Method  
>> matches(java.lang.String) not found in class java.lang.S
>> tring.
>>         if(humanSize.matches(regex)) {
>>                             ^
>>
>> You missed Kev's last change
>>       rev 486465 - remove Java1.4 specific methods from  
>> parseHumanSizes
>
That is true.


> Also the unittests for hasfreespace-test do not check for java6:
> [au:antunit] Build File:
> /x1/gump/public/workspace/ant/src/tests/antunit/taskdefs/condition/ 
> hasfreespace-test.xml
> [au:antunit] Tests run: 4, Failures: 0, Errors: 4, Time elapsed:  
> 0.045 sec
> [au:antunit] Target: test-enough-space-human  caused an ERROR
> [au:antunit] 	at line 11, column 20
> [au:antunit] 	Message: au:assertTrue doesn't support the nested
> "hasfreespace" element.
>
>
> Peter

I saw the same when running the tests.

Since I did my build under JDK 1.5, it did not compile the  
implementation for this Java 1.6 specific class.

Antoine


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message