ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40882] New: - Echo task doesn't emit [echo] when message is blank.
Date Fri, 03 Nov 2006 02:54:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40882>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40882

           Summary: Echo task doesn't emit [echo] when message is blank.
           Product: Ant
           Version: unspecified
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: scohen@apache.org


In the following script fragment:

<property name="empty.prop" value=""/>
<echo/> 
<echo>${empty.prop}</echo> 
<echo message="${empty.prop}"/> 

all three echo tags produce blank lines without the [echo] label.  While there
are those who feel that <echo/> is a cheap way to prettyprint blank lines into
build output, it is incorrect behavior.

See ant-dev mailing list thread here:
http://marc.theaimsgroup.com/?l=ant-dev&m=116217612417452&w=2
and especially Dominque Devienne's reply:
http://marc.theaimsgroup.com/?l=ant-dev&m=116221549727883&w=2

"Any task output should be
prefixed with the task name in non-emacs mode. --DD"

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message