ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40914] - Copy task completed, but files not fully copied yet
Date Tue, 07 Nov 2006 12:02:56 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40914>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40914


stevel@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO




------- Additional Comments From stevel@apache.org  2006-11-07 04:02 -------
When Ant's copy completes, the files have been copied and closed. 

If it was a network, I'd suspect some caching thing at play. but if it happens
locally, then its something else. 

Here's my theory. Your build file sets up the classpath before the files are
copied, with some <fileset dir="lib" includes="**/*.jar" />. The files are
copied that first run, but not picked up, as the fileset was created too early.

Move the fileset/path setup down to just before you compile.

Marking as needinfo, to see what happens after you do this.



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message