ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: FW: antunit branch for 1.6.x compatibility
Date Sun, 29 Oct 2006 20:23:24 GMT
On Sat, 28 Oct 2006, Vladimir Egorov <vegorov@bea.com> wrote:
> From: Stefan Bodewig [mailto:bodewig@apache.org]

>> Which parts of AntUnit would you use?
>> Only the assertions or the tasks and listeners as well?
> 
> Currently we are only interested in asserts library.

Which is pretty easy to keep working cross-version since most of it
consists of macrodefs anyway.  We certainly couldn't use conditions
created in 1.7 (regexp, for example).

> It is easy to write them, but it would not be good if the same thing
> was done differently in different projects.

Of course not.

> What is your take on this? I mean, some generic asserts are the same
> for AntUnit, WebTest, and TestLogic, but some are specific to the
> project.  Do you think it is worth the effort to standardize on a
> common asserts library and what should be the extension mechanism?

I'd leave them in AntUnit and think it should be possible to keep a
1.6.5 compatible branch for them.

> In the future, we may be interested in AntUnit runtime (task and
> listeners) as well, depending on the direction our project takes.

Which would require more work since more code is written in Java then.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message