ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40776] New: - a problem compiling a Java 5 project with generics
Date Tue, 17 Oct 2006 16:31:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40776>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40776

           Summary: a problem compiling a Java 5 project with generics
           Product: Ant
           Version: 1.6.5
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: cbotev@gmail.com


Hi!

I've come accross the following problem trying to compile Java 5
classes with generics using Ant 1.6.5. I've attached the archived project
with sample Java classes and a build.xml file.

A clean build of the above project works just fine and compiles
without a problem. If after that, I touch the Test3.java file the
build fails with the following error:

 [javac] C:\src\appforge\test\src\test\Test3.java:5: incompatible types
 [javac] found   : test.Base
 [javac] required: test.Sub
 [javac] public Sub p() {return this.getV();}
 [javac] ^
 [javac] 1 error

Initially, I thought that this was a problem with the Java compiler.
After touching Test3.java, I tried running javac manually:

javac -sourcepath src -d bin -g -source 1.5 -target 1.5 src\test\*.java

It turned out that with the above command-line the project compiled
OK. The project also compiles without a problem in Eclipse 3.2.1.

Upon further experimentation, if I uncomment the method in Test2.java
fixes the problem. Touching Test3.java does not break the build.

I've been able to reproduce the problem both on Windows XP with JDK 1.5.0_08 and
on RedHat EL4 with 1.5.0_07.

Thanks,
Chavdar

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message