ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Ant Wiki] Update of "Ant17/Planning" by peterreilly
Date Fri, 06 Oct 2006 09:19:20 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Ant Wiki" for change notification.

The following page has been changed by peterreilly:
http://wiki.apache.org/ant/Ant17/Planning

The comment on the change is:
Move stuff that will not be implemented to WONTFIX

------------------------------------------------------------------------------
  
   * Fix for key IDE bugs (see eclipse, netbeans bugzillas) [all]
  
-  * <classloader> to allow adding of jars to the current classloader (would solve a
''lot'' of problems at the cost of some issues) http://issues.apache.org/bugzilla/show_bug.cgi?id=28228
[peter] (status RE "some issues" risk? -MJB)
  
   * Junit 4 integration to a level that Ant-dev and junit are happy.
  
@@ -66, +65 @@

  
  Less critical, but still nice. Adding here is also a statement of intent.
  
+ 
-  * Java1.5 environment fetching. Ideally as part of a rework of Execute.getProcessEnv()
(if we plan to retrofit commons-exec in source after it stabilizes, maybe we should forego
this at present? -MJB)
-  * Doc improvements.
   * <propertyfile> in java tasks for loading properties straight from a file.
   * reduce number of outstanding bugzilla ''bugs'' by fixing them or declaring WONTFIX/Invalid.
   * reduce number of outstanding bugzilla ''enhancements'' by implementing some, or closing
them off.
@@ -129, +127 @@

   * Java1.6 beta, MacOS X (I've checked apple/developer (ADC) and so far no mention of Java6
on OSX - Kev)
   * OpenVMS, Any Java
  
- == WONTFIX ==
+ == WONTFIX this release ==
  
  Definitely not in this release. Pull stuff down here when scrubbed from the previous lists.
   * <issigned> to do signature checking (identify signatory). fundamentally impossible.
   * <libraries>: maven2, security. Use Maven2 artifact library instead.
+  * <classloader> to allow adding of jars to the current classloader (would solve a
''lot'' of problems at the cost of some issues)
+    this has been discussed at dev@ant.apache.org - something will be done for ant 1.8.
+  * Java1.5 environment fetching. Ideally as part of a rework of Execute.getProcessEnv()
(if we plan to retrofit commons-exec in source after it stabilizes, maybe we should forego
this at present? -MJB)
+  * Doc improvements.
  

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message