ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40619] - http condition gives error 504
Date Wed, 27 Sep 2006 15:18:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40619>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40619


peterreilly@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|http task gives error 504   |http condition gives error
                   |                            |504




------- Additional Comments From peterreilly@apache.org  2006-09-27 15:18 -------
There has been changes in ant 1.7 dealing with http proxy
WHATSNEW
* On Java1.5+, Ant automatically sets the system property
  java.net.useSystemProxies to true, which gives it automatic use of the local
  IE (Windows) or Gnome2 (Unix/Linux) proxy settings. This may break any build
  file that somehow relied on content outside the firewall being unreachable:
  use the -noproxy command-line option to disable this new feature.
  Note that the Java1.5 proxy configuration system still does not
  appear to work reliably on Windows or Linux.

504 is:
10.5.5 504 Gateway Timeout

The server, while acting as a gateway or proxy, did not receive a timely
response from the upstream server specified by the URI (e.g. HTTP, FTP, LDAP) or
some other auxiliary server (e.g. DNS) it needed to access in attempting to
complete the request.

      Note: Note to implementors: some deployed proxies are known to
      return 400 or 500 when DNS lookups time out.

The address used (10.35.1.1) is a private address and should
not go to the proxy server, so there is a configuration issue.

Try using ant -noproxy and also check the ie settings:

ie->tools->internet options->connections->local area network(lan) settings
and ensure that the "bypass proxy for local addresses" is set



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message