ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Glick <jesse.gl...@sun.com>
Subject Re: svn commit: r432728 - in /ant/core/trunk/src/main/org/apache/tools/ant/util/regexp: RegexpFactory.java RegexpMatcherFactory.java
Date Tue, 22 Aug 2006 23:18:38 GMT
Antoine Levy-Lambert wrote:
> does unexpected reason here mean that the JDK has a version >= 1.4
> and the JDK 1.4 regexp package is not available ?

Yes - for example, if you built Ant using JDK 1.3 and then run using 1.4 
(with no extra libs in CP), it will fail since the 1.4 regexp adapter 
was never compiled. Previously it just said that no regexp impl could be 
found, which was pretty mysterious. Now the error specifically mentions 
the Ant adapter class, which helps you narrow in on the problem. Of 
course the official Ant binaries would be built with this class 
compiled, but if you build yourself this patch can be helpful.

-J.

-- 
jesse.glick@sun.com  x22801  netbeans.org  ant.apache.org
       http://google.com/search?q=e%5E%28pi*i%29%2B1


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message