ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40152] New: - rmic: Ant 1.7 adds -vcompat when building iiop stubs
Date Tue, 01 Aug 2006 13:55:00 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40152>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40152

           Summary: rmic: Ant 1.7 adds -vcompat when building iiop stubs
           Product: Ant
           Version: 1.7Alpha (nightly)
          Platform: Other
        OS/Version: OpenVMS
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: powell.hazzard@hp.com
                CC: powell.hazzard@hp.com


Hello,

   The RMIC task with Ant 1.7 appears to adds a default "-vcompat" option for 
compatibility.  Since the default changed in Java 5.0 I can see where we might 
need to add this option for compatibility; however when building IIOP stubs I 
don't believe the “-vcompat" options should be supplied as a default.  If we 
supply this option rmic attempts to build a JRMP stub and not an IIOP stub 
file.
 
Example:   While testing the Ant 1.7 against the jboss junit tests I came 
across the following failure:
...
     [rmic] '-vcompat'
     [rmic] '-iiop'
     [rmic] '-g'
     [rmic]
     [rmic] The ' characters around the executable and arguments are
     [rmic] not part of the command.
     [rmic] Files to be compiled:    
org.jboss.test.txpropiiop.interfaces.a.SessionA    
org.jboss.test.txpropiiop.interfaces.a.Sessi
onAHome    org.jboss.test.txpropiiop.interfaces.b.SessionB    
org.jboss.test.txpropiiop.interfaces.b.SessionBHome
     [rmic] error: org.jboss.test.txpropiiop.interfaces.b.SessionBHome is an 
interface; stubs are needed only for remote object clas ses.
...

   "-vcompat" was not supplied during with Ant 1.6.5, and if I supply the 
following patch to DefaultRmiAdapter.java, Ant 1.7 builds the rmi test stubs 
correctly.  This also continues to supply “-vcompat” as a default option if “-
iiop” is not supplied.

# diff DefaultRmicAdapter.java_orig DefaultRmicAdapter.java > 
DefaultRmicAdapter.diffs
# cat DefaultRmicAdapter.diffs
209c209,210
<         cmd.createArgument().setValue(stubOption);
---
>         if (stubVersion == null && !attributes.getIiop())
>            cmd.createArgument().setValue(stubOption);

Note: this is not specific to OpenVMS; I receive the same failures under 
Windows as well.

Best Regards,

Powell Hazzard
HP Java Engineering

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message