ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject AW: [GUMP@vmgump]: Project antunit-test (in module ant-antlibs) failed
Date Tue, 06 Jun 2006 10:58:37 GMT
ant-testutil.jar is only build via target "test-jar", so usually you havent created that. It's
also not part of the distro (yet?).

Jan

>-----Urspr√ľngliche Nachricht-----
>Von: Steve Loughran [mailto:stevel@apache.org] 
>Gesendet: Dienstag, 6. Juni 2006 11:57
>An: Ant Developers List
>Betreff: Re: [GUMP@vmgump]: Project antunit-test (in module 
>ant-antlibs) failed
>
>Gump Integration Build wrote:
>> To whom it may engage...
>>         
>> This is an automated request, but not an unsolicited one. For more 
>> information please visit http://gump.apache.org/nagged.html,
>> and/or contact the folk at general@gump.apache.org.
>> 
>> Project antunit-test has an issue affecting its community 
>integration.
>> This issue affects 1 projects,
>>  and has been outstanding for 4 runs.
>> The current state of this project is 'Failed', with reason 
>'Build Failed'.
>> For reference only, the following projects are affected by this:
>>     - antunit-test :  Task and Type Libraries for Apache Ant
>> 
>> 
>> Full details are available at:
>>     
>> 
>http://vmgump.apache.org/gump/public/ant-antlibs/antunit-test/index.ht
>> ml
>> 
>> That said, some information snippets are provided here.
>> 
>> The following annotations (debug/informational/warning/error 
>messages) were provided:
>>  -DEBUG- Dependency on ant-testutil exists, no need to add 
>for property ant-testutil.jar.
>>  -INFO- Failed with reason build failed
>> 
>> 
>
>test:
>     [junit] Testsuite: org.apache.ant.antunit.AntUnitTest
>     [junit] Tests run: 1, Failures: 0, Errors: 1, Time 
>elapsed: 0.934 sec
>
>     [junit] Testcase: testBase took 0.903 sec
>     [junit] 	Caused an ERROR
>     [junit] Tests failed with 1 failure and 1 error
>     [junit]
>/x1/gump/public/workspace/ant-antlibs/antunit/src/etc/testcases
>/antunit.xml:23: 
>Tests failed with 1 failure and 1 error
>     [junit] 	at 
>org.apache.ant.antunit.AntUnit.execute(AntUnit.java:84)
>     [junit] 	at 
>org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
>     [junit] 	at 
>sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     [junit] 	at 
>sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccesso
>rImpl.java:39)
>     [junit] 	at 
>sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMetho
>dAccessorImpl.java:25)
>     [junit] 	at java.lang.reflect.Method.invoke(Method.java:585)
>     [junit] 	at 
>org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUti
>ls.java:104)
>     [junit] 	at org.apache.tools.ant.Task.perform(Task.java:375)
>     [junit] 	at org.apache.tools.ant.Target.execute(Target.java:356)
>     [junit] 	at 
>org.apache.tools.ant.Target.performTasks(Target.java:384)
>     [junit] 	at 
>org.apache.tools.ant.Project.executeSortedTargets(Project.java:1268)
>     [junit] 	at 
>org.apache.tools.ant.Project.executeTarget(Project.java:1237)
>     [junit] 	at 
>org.apache.tools.ant.BuildFileTest.executeTarget(BuildFileTest.
>java:276)
>     [junit] 	at 
>org.apache.ant.antunit.AntUnitTest.testBase(AntUnitTest.java:33)
>     [junit] 	at 
>sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>     [junit] 	at 
>sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccesso
>rImpl.java:39)
>     [junit] 	at 
>sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMetho
>dAccessorImpl.java:25)
>     [junit] 	at java.lang.reflect.Method.invoke(Method.java:585)
>     [junit] 	at junit.framework.TestCase.runTest(TestCase.java:164)
>     [junit] 	at junit.framework.TestCase.runBare(TestCase.java:130)
>     [junit] 	at 
>junit.framework.TestResult$1.protect(TestResult.java:110)
>     [junit] 	at 
>junit.framework.TestResult.runProtected(TestResult.java:128)
>     [junit] 	at junit.framework.TestResult.run(TestResult.java:113)
>     [junit] 	at junit.framework.TestCase.run(TestCase.java:120)
>     [junit] 	at junit.framework.TestSuite.runTest(TestSuite.java:228)
>     [junit] 	at junit.framework.TestSuite.run(TestSuite.java:223)
>     [junit] 	at 
>org.junit.internal.runners.OldTestClassRunner.run(OldTestClassR
>unner.java:35)
>     [junit] 	at 
>junit.framework.JUnit4TestAdapter.run(JUnit4TestAdapter.java:32)
>     [junit] 	at 
>org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.ru
>n(JUnitTestRunner.java:354)
>     [junit] 	at 
>org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.la
>unch(JUnitTestRunner.java:771)
>     [junit] 	at 
>org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.ma
>in(JUnitTestRunner.java:640)
>
>     [junit] TEST org.apache.ant.antunit.AntUnitTest FAILED
>     [junit] Testsuite: org.apache.ant.antunit.AssertTest
>     [junit] Tests run: 32, Failures: 0, Errors: 0, Time 
>elapsed: 3.209 sec
>
>Not sure what is going on here, we arent getting very good 
>diagnostics (uh oh). When I try and run from my laptop, It 
>doesnt find ant-testutil.jar, which is a bad sign. Do I need 
>to point to it in build.properties or something?
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org For 
>additional commands, e-mail: dev-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message