ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject AW: # character causes problem parsing -lib paths
Date Fri, 12 May 2006 05:38:11 GMT
Just a question .... have I missed a vote dropping JDK 1.2???
I found a discussion about that [1], but 
- that was not a vote
- had some points keeping 1.2


Jan

[1] http://marc.theaimsgroup.com/?l=ant-dev&m=111281782123728&w=2 




>-----Urspr√ľngliche Nachricht-----
>Von: Peter Reilly [mailto:peter.kitt.reilly@gmail.com] 
>Gesendet: Mittwoch, 10. Mai 2006 12:33
>An: Ant Developers List
>Betreff: Re: # character causes problem parsing -lib paths
>
>I have just tested with java 1.3. and indeed # does not work 
>there. I have not looked into this too much, but can only 
>assume that this is due to a bug with java 1.3 which was fixed 
>for java 1.4. I am not too sure if ant can work-around this issue.
>
>On 5/10/06, Paul.Mackay@nokia.com <Paul.Mackay@nokia.com> wrote:
>>
>> Hello,
>>
>> I have tested an SVN snapshot of Ant with the fix in for 
>parsing # in 
>> the path. It works using Java 1.4.2 but not Java 1.3.1. My 
>> understanding is that 1.3 is intended to be supported for Ant 1.7 
>> based on this page http://wiki.apache.org/ant/Ant17/Planning. Is it 
>> possible to test this functionality using 1.3?
>>
>> thanks
>>
>> paul
>>
>> >-----Original Message-----
>> >From: ext Peter Reilly [mailto:peter.kitt.reilly@gmail.com]
>> >Sent: Wednesday, April 19, 2006 3:52 AM
>> >To: Ant Developers List
>> >Subject: Re: # character causes problem parsing -lib paths
>> >
>> >I have just checked.
>> >This is a problem - the ant launcher code does some conversion of 
>> >file names to URLs. The '#' character is not converted The only 
>> >work-around (at the moment) is to use symbolic links.
>> >I have made a change to ant SVN to fix this.
>> >
>> >Peter
>> >
>> >On 4/19/06, Paul.Mackay@nokia.com <Paul.Mackay@nokia.com> wrote:
>> >>
>> >> Hello,
>> >>
>> >> I have found that if I specify a -lib option with a path
>> >that contains
>> >> a hash "#" character, it cannot find the libraries. Without the # 
>> >> character in the path they can be picked up fine.
>> >>
>> >> This is not easily avoided in our environment, as we use Synergy 
>> >> for SCM, which defaults to using # in the path when checking out
>> >projects.
>> >> This can be changed, but that is not desirable.
>> >>
>> >> Is this a known bug? Does anyone know of any workarounds?
>> >>
>> >> Many thanks
>> >>
>> >> paul
>> >>
>> >>
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org For 
>additional 
>> commands, e-mail: dev-help@ant.apache.org
>>
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message