ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Added (very basic) antversion condition
Date Thu, 25 May 2006 13:51:35 GMT
On Thu, 25 May 2006, Kevin Jackson <foamdino@gmail.com> wrote:
> Hi,
> 
> Had some free time today so built a basic antversion condition.
> (see commits)
> 
> Currently only supports x.y, not x.y.z versioning, currently the
> only way I can see of doing the full versioning (with alpha/beta/rc1
> etc) is to using something similar to the javascript suggestion by
> Jan

If it wasn't for the rc's and all that I'd suggest you use
org.apache.tools.ant.taskdefs.optional.extension.DeweyDecimal.

Do you really think the condition needs to differentiate 1.6.5 from
1.7.0-alpha1 from 1.7.0?  I'd say considering 1.7.0 alpha the same as
1.7.0 should be fine in most cases.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message