ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39301] New: - Classpath with '\' as last character breaks the Launcher when using ant.bat
Date Thu, 13 Apr 2006 13:08:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39301>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39301

           Summary: Classpath with '\' as last character breaks the Launcher
                    when using ant.bat
           Product: Ant
           Version: 1.6.5
          Platform: Other
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Wrapper scripts
        AssignedTo: dev@ant.apache.org
        ReportedBy: Vampire@Masters-of-Disaster.de


In ant.bat there is used

%ANT_ARGS% -cp "%CLASSPATH%" %ANT_CMD_LINE_ARGS%

in the "targets" :runAntWithClasspath and :runAntWithJikesAndClasspath.
The problem is, if %CLASSPATH% has a '\' as last character, this escapes the 
quotation mark in the commandline, so any following %ANT_CMD_LINE_ARGS% 
are "ignored" because they count as part of the classpath.

Solution:
Change the order to:
%ANT_ARGS% %ANT_CMD_LINE_ARGS% -cp "%CLASSPATH%"
So the classpath is the last element on the commanline and therefor may span 
until the end.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message