ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kev Jackson <kevin.jack...@it.fts-vn.com>
Subject Re: Ant 1.7 beta?
Date Tue, 25 Apr 2006 10:02:53 GMT
>
> I'm trying to set up a conf call with the junit team, to see how best 
> to go with the junit4 support. I am currently thinking
> -<junit> stays 3.8.x only.
> -we add a new junit antlib for junit4 support, design it to work on 
> 1.6.5 and 1.7
> -maybe hand off ownership of the antlib to the junit team, if they 
> want to gain that tight coupling and take on the costs.
>
That sounds like a good plan - it would be much better if the JUnit 
people can support their own JUnit antlib

>
> WL itself hurts. I know people hate jboss for its worst-in-class 
> classloader, but it doesnt make such a mess of your machine. Mind you, 
> I've never tried WebSphere.

Ah yes WL is one of my least favourite pieces of software - the 'hacked 
up not quite Ant' that it sticks on your path (before your current 
ANT_HOME), the 'not eclipse' IDE (WL Workshop) - great let's strip out 
the good features of eclipse (refactoring support, CVS/SVN support) and 
leave you with a bloated IDE that only works with WL, the jrocket vm - 
which doesn't like code compiled with the Sun JDK, but interestingly has 
no problems with code compiled with Jikes.  A whole host of wizzy gui 
configurators/installers, but the shell scripts are placed in different 
location depending on linux/windows.  And a hot-deploy mode that doesn't 
work (unless you use the web application / server admin tool to deploy) 
- which defeats the point of the 'special' bundled Ant, or the supplied 
shell scripts.

I've used a very old version of WebSphere (3.5) and it sucked, given the 
time WL 8+ has had since 2000 (when I used that bug-ridden steaming pile 
of <expletive deleted>), and coming from a completely different company, 
I hoped for something much better - but no it sucked too, but in a 
different way.  I'm not sure, but I suspect that all J2EE appservers 
suck, I just haven't had the misfortune to try them all (yet).

(sorry had to rant about WL, two projects using it back-to-back and it 
doesn't do anything for me - tomcat + spring or apache + rails would be 
much better for both projects)

Kev

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message