ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38732] - rmic task doesn't work with -Xnew and JDK 6.0
Date Sat, 29 Apr 2006 15:27:05 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38732>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38732





------- Additional Comments From bodewig@apache.org  2006-04-29 15:27 -------
This is rather strange.  I've added to tests to Ant's tests in SVN, both setting
-Xnew, one forking, one not.

If I run the corresponding targets directly, I get the behavior Robert describes -
but only in the not-forking case.

If I run the tests via <junit>, either both fail (when I don't fork JUnit) or both
pass (when I fork JUnit).

Looks like a classloader issue with Sun's rmic at first glance.  It doesn't seem
to like it when Ant pulls in tools.jar via the launcher logic.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message