ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32884] - [PATCH] PathConvert on Windows should process forward and back slashes equivalently
Date Wed, 19 Apr 2006 22:31:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32884>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32884





------- Additional Comments From joe@kafsemo.org  2006-04-19 22:31 -------
(In reply to comment #2)
> this would be better with a concrete example of what doesn't work

In my case, running under Windows and using forward slashes:

  <pathconvert property='test.path' pathSep=' '>
   <map from='C:/Build/' to=''/>
   <path>
    <pathelement location='C:/Build/lib'/>
   </path>
  </pathconvert>

  <echo>${test.path}</echo>

The prefix isn't removed. Using backslashes in both the prefix and the path
works, but I'm used to being able to use forward slashes in Ant under any platform.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message