ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39143] New: - Ant.bat is broken.
Date Wed, 29 Mar 2006 12:35:32 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39143>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39143

           Summary: Ant.bat is broken.
           Product: Ant
           Version: 1.6.3
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: regression
          Priority: P2
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: silver_hl@hotmail.com


Ant doesn't have the -cp arg. Only javac has it.
Should be "-lib" and not "-cp".            

When I do: 

"C:\apache-ant-1.6.3\bin\ant.bat" -buildfile .\Source\J2EE\build.xml jar

The output gives:
Unknown argument: -cp

In versions 1.6.2, 1.6.1, 1.6.0, 1.5.4, 1.5.3.1, 1.5.2 everything is OK. In 
1.6.3, 1.6.4 and 1.6.5 it gives that error.

The workaround is to edit the ant.bat and replace "-cp" for "-lib".

I am using sun jdk 1.5.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message