ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: <javac> on java1.5
Date Thu, 23 Mar 2006 19:22:58 GMT
On Thu, 23 Mar 2006, Steve Loughran <stevel@apache.org> wrote:
> Now that Gump has switched to java1.5, its showing up some problems
> in javac.
> 
> Specifically, it appears to be defaulting to source=1.5

Please take the time and look into the manual page of the task, in
particular the bold-face notes on the target and source attributes ;-)

> This is breaking backwards compatibility for builds.

Quite the opposite.  Changing javac's behaviour to default to 1.3 or
something would have broken working builds on Java 1.5 when we started
to work on 1.5 support for 1.6(.2 or something).

> Also, <javac> shouldnt warn people about source=1.2 on every
> compile:
> 
>   Once per build should suffice.

+1

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message