ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: <javac> on java1.5
Date Thu, 23 Mar 2006 16:10:04 GMT
Peter Reilly wrote:
> #1 would not be backwardly compatible !
> 
> I am not too sure about #2. In the ant build
> file we had to deal with this issue for a while,
> it may be as well to get other project 1.5 aware.
> Also new projects would have to set things so
> that 1.5 (and higher) would work.
> 

Telling people to say "you must declare a java version" is no big deal; 
its easily done. But there are a lot of projects out there that built 
happily, and which now dont because gump upgraded.

Furthermore, what if we can't upgrade them all? There are old projects 
out there that havent had a change for 12+ months, but which still work. 
Its only that they dont compile on java1.5.

if we the properties ant._internal._javac.source and 
ant._internal._javac.target that set the defaults for javac, then you 
can also use them on the command line to build anything 'legacy', 
without touching the build file.


-steve




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message