ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <>
Subject Re: <javac> on java1.5
Date Thu, 23 Mar 2006 15:21:10 GMT
> Now, when <rmic>'s dependency logic broke moving up to 1.5, I fixed it
> by forcing the proxy generation to be downwards compatible, so
> everything behaved as on a 1.3 or 1.4 box.

True, and was probably the right choice. But there are fewer <rmic>
users than <javac> users, so impacts less people.

> Here are some options
> (1) tweak javac to build at 1.4 or below unless stated.

I think this would be "surprising", since <javac> would behave
differently than javac the command line app.

> (2) provide a back door switch to let gump control the jvm version. that
> way old code can be built under a new compiler.
> #2 has appeal.

Just like you, I'd rather avoid a magic property for gump, but I don't
see another solution, since I'm not fond of #1. I won't -1 #1 yet, but
I don't like it. --DD

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message