ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39037] - Illegal character ' ' in toolsJar URL is not escaped
Date Sun, 26 Mar 2006 02:06:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39037>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39037





------- Additional Comments From william.barker@wilshire.com  2006-03-26 03:06 -------
(In reply to comment #1)
> I can work around it by building Ant with a 1.3.1 JVM.  For a 1.4+ JVM, a 
> better patch is to in Locator.fromURI(String), simply swallow (or log) the 
> IllegalArgumentException, and continue on trying the 1.3 logic.  This builds 
> Ant successfully as well.
Ok, I take it back.  To get a working Ant that will work with 1.4+, it isn't 
enough to build with 1.3.1.  The path to Locator.fromURI is needed as well.


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message