ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39037] - Illegal character ' ' in toolsJar URL is not escaped
Date Sat, 25 Mar 2006 23:43:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39037>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39037





------- Additional Comments From william.barker@wilshire.com  2006-03-25 23:43 -------
I just hit this one as well.  It also occurs if you co Ant into a location 
that has a ' ' in the path (common enough under Windows :).  To fix this case 
with the patch in #0, you would also need to apply it to 
Locator.getLocationURLs, and anyplace else that File.toURL is called.  Not 
very pretty :(.

I can work around it by building Ant with a 1.3.1 JVM.  For a 1.4+ JVM, a 
better patch is to in Locator.fromURI(String), simply swallow (or log) the 
IllegalArgumentException, and continue on trying the 1.3 logic.  This builds 
Ant successfully as well.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message