ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 38914] - ant -p doesn't display targets correctly when CLASSPATH=""
Date Tue, 14 Mar 2006 01:25:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=38914>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=38914





------- Additional Comments From kevin.jackson@it.fts-vn.com  2006-03-14 01:25 -------
(In reply to comment #3)
> Regarding the java version (remark from kev): Did you also set your PATH
> accordingly. the java executable is not selected via JAVA_HOME but via your
> path, and lacking that <some magic, maybe registry>.
> 

I tracked this to the %SYSTEM% on the path - Java5+ installs java.exe into
windows/system32 - which completely took me by suprise.  Changing the order of
the PATH variable fixed it (put JAVA_HOME first), but Applets still use the
registry in some way and I have yet to work around that (though it's a *much*
lower priority as I rarely use the Java web plugin)

Anyway - just recording this in case people stumble on it from Google.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message