ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Oxspring <roxspr...@imapmail.org>
Subject Re: <signjar> and exit code 128
Date Tue, 31 Jan 2006 11:34:14 GMT
Steve Loughran wrote:
> Rob Oxspring wrote:
>> Hi,
>>
>> I've been having problems with the signjar task occasionally failing 
>> with "exec returned: 128" for a long time now.  The problem isn't 
>> always reproducible and often disappears by simply cleaning the build 
>> area and starting again; sometimes this technique doesn't work though.
>>
>> I checked the jarsigner sources and they simply have exit codes of 0 
>> and 1 to indicate success and failure, so jarsigner is presumably not 
>> to blame.  From a little googling it looks like this might be a 
>> cmd.exe issue as there is a generic Windows error message associated 
>> with 128 that seems relevant:
>>
>>   C:\>net helpmsg 128
>>
>>   There are no child processes to wait for.
>>
>> I'm guessing this means that the jarsigner.exe is completing really 
>> quickly, although I suppose it could mean that it wasn't launched at 
>> all.  I'd really like to get this problem solved as it would make our 
>> build server that bit more reliable.
>>
>> Has anyone else seen this sort of thing happening before? any 
>> recommended solutions? do I just add an ignoreexitcode128 attribute to 
>> the signjar/exectask?
> 
> Not seen this, and we do a lot of signing; it may depend on jar size. 
> Now, sometimes java runtimes return funny numbers, so, say HPUX returns 
> 255 instead of -1. But that is an OS issue, which we would have 
> encountered on windows before...
> 

I've been looking into this some more and it turns out that our 
development boxes very rarely suffer this problem while the build server 
is the only one that sometimes does... I suspect this is due to the 
build server having twin processors.  To test this I've set the 
processor affinity to make the builds use one processor only and things 
seem to be working out.  It'd be great if there were a solution that'd 
let us use both processors but I'll have to ponder that for a while.

Thanks for you time,

Rob

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message